import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[0-9]{1,3}\\.){3}[0-9]{1,3}(?=\\s|\\)|$)";
final String string = "Nmap scan report for whm.ixcsoft.com.br (45.174.128.220)\n"
+ "Host is up (0.047s latency).\n"
+ "Nmap scan report for 231.128.174.45.ixcsoft.com.br (45.174.128.231)\n"
+ "Host is up (0.048s latency).\n"
+ "Nmap scan report for 192.168.25.2\n"
+ "Host is up (0.048s latency).\n"
+ "Nmap scan report for 192.168.25.3\n"
+ "Host is up (0.048s latency).";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}