use strict;
my $str = 'Nmap scan report for whm.ixcsoft.com.br (45.174.128.220)
Host is up (0.047s latency).
Nmap scan report for 231.128.174.45.ixcsoft.com.br (45.174.128.231)
Host is up (0.048s latency).
Nmap scan report for 192.168.25.2
Host is up (0.048s latency).
Nmap scan report for 192.168.25.3
Host is up (0.048s latency).';
my $regex = qr/(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?=\s|\)|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}