import Foundation
let pattern = #"(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?=\s|\)|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Nmap scan report for whm.ixcsoft.com.br (45.174.128.220)
Host is up (0.047s latency).
Nmap scan report for 231.128.174.45.ixcsoft.com.br (45.174.128.231)
Host is up (0.048s latency).
Nmap scan report for 192.168.25.2
Host is up (0.048s latency).
Nmap scan report for 192.168.25.3
Host is up (0.048s latency).
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)