const regex = /(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?=\s|\)|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[0-9]{1,3}\\.){3}[0-9]{1,3}(?=\\s|\\)|$)', 'g')
const str = `Nmap scan report for whm.ixcsoft.com.br (45.174.128.220)
Host is up (0.047s latency).
Nmap scan report for 231.128.174.45.ixcsoft.com.br (45.174.128.231)
Host is up (0.048s latency).
Nmap scan report for 192.168.25.2
Host is up (0.048s latency).
Nmap scan report for 192.168.25.3
Host is up (0.048s latency).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}