package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[^"#]*".*"[^"#]*|[^"#]*)(#.*)?$`)
var str = `{ # comment 1
"hello": "Wor#d", "Bye": "\"M#rk\"",# comment" 2
"quote": "\"th#t's\" what she said", # comment 3
"list": [1, 1, "#", "\"", 5, 8] # comment 4 with "quotes"
}
# comment 5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}