// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?mi)^(?:[^"#]*".*"[^"#]*|[^"#]*)(#.*)?$"##).unwrap();
let string = "{ # comment 1
\"hello\": \"Wor#d\", \"Bye\": \"\\\"M#rk\\\"\",# comment\" 2
\"quote\": \"\\\"th#t's\\\" what she said\", # comment 3
\"list\": [1, 1, \"#\", \"\\\"\", 5, 8] # comment 4 with \"quotes\"
}
# comment 5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}