use strict;
my $str = '{ # comment 1
"hello": "Wor#d", "Bye": "\\"M#rk\\"",# comment" 2
"quote": "\\"th#t\'s\\" what she said", # comment 3
"list": [1, 1, "#", "\\"", 5, 8] # comment 4 with "quotes"
}
# comment 5';
my $regex = qr/^(?:[^"#]*".*"[^"#]*|[^"#]*)(#.*)?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}