# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[^)(]*\(|\)[^)(]*)(*SKIP)(*F)|\s//gm;t' <<< "foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )
"