#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[^)(]*\(|\)[^)(]*)(*SKIP)(*F)|\s"
Local $sString = "foobar baz blah (some sample text in here) and some more" & @CRLF & _
"" & @CRLF & _
"a b c (d e f) g ( )" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)