// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[^)(]*\(|\)[^)(]*)(*SKIP)(*F)|\s").unwrap();
let string = "foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}