package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^)(]*\(|\)[^)(]*)(*SKIP)(*F)|\s`)
var str = `foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}