re = /(?:[^)(]*\(|\)[^)(]*)(*SKIP)(*F)|\s/m
str = 'foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result