using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script.*?/script>(*SKIP)(*FAIL)|text|simple";
string substitution = @"***replacement***";
string input = @"This has no replacements
This simple text has no script tag
This simple text ends with a script tag <script language=""javascript"">simple simple text text</script>
This is simple html text is split by a script tag <script language=""javascript"">simple simple text text</script> text
<script language=""javascript"">simple simple text text</script> this text starts with a script tag";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}