import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script.*?/script>(*SKIP)(*FAIL)|text|simple";
final String string = "This has no replacements\n\n"
+ "This simple text has no script tag\n\n"
+ "This simple text ends with a script tag <script language=\"javascript\">simple simple text text</script>\n\n"
+ "This is simple html text is split by a script tag <script language=\"javascript\">simple simple text text</script> text\n\n"
+ "<script language=\"javascript\">simple simple text text</script> this text starts with a script tag";
final String subst = "***replacement***";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}