use strict;
my $str = 'This has no replacements
This simple text has no script tag
This simple text ends with a script tag <script language="javascript">simple simple text text</script>
This is simple html text is split by a script tag <script language="javascript">simple simple text text</script> text
<script language="javascript">simple simple text text</script> this text starts with a script tag';
my $regex = qr~<script.*?/script>(*SKIP)(*FAIL)|text|simple~p;
my $subst = '***replacement***';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";