import Foundation
let pattern = #"<script.*?/script>(*SKIP)(*FAIL)|text|simple"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This has no replacements
This simple text has no script tag
This simple text ends with a script tag <script language="javascript">simple simple text text</script>
This is simple html text is split by a script tag <script language="javascript">simple simple text text</script> text
<script language="javascript">simple simple text text</script> this text starts with a script tag
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"***replacement***"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)