// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<script.*?/script>(*SKIP)(*FAIL)|text|simple").unwrap();
let string = "This has no replacements
This simple text has no script tag
This simple text ends with a script tag <script language=\"javascript\">simple simple text text</script>
This is simple html text is split by a script tag <script language=\"javascript\">simple simple text text</script> text
<script language=\"javascript\">simple simple text text</script> this text starts with a script tag";
let substitution = "***replacement***";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}