$re = '~<script.*?/script>(*SKIP)(*FAIL)|text|simple~';
$str = 'This has no replacements
This simple text has no script tag
This simple text ends with a script tag <script language="javascript">simple simple text text</script>
This is simple html text is split by a script tag <script language="javascript">simple simple text text</script> text
<script language="javascript">simple simple text text</script> this text starts with a script tag';
$subst = "***replacement***";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;