package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<title.*?>(.*?)<\/title>`)
var str = `<!doctype html>\n<html lang=\"en\" itemscope itemtype=\"https://schema.org/WebPage\">\n<head>\n<meta charset=\"utf-8\"><meta name=\"referrer\" content=\"always\" />\n<title itemprop=\"name\">title I need to select.</title>\n<meta itemprop=\"description\" name=\"description\" content=\><title itemprop=\"name\">title I need to select.</title>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}