$re = '/<title.*?>(.*?)<\/title>/';
$str = '<!doctype html>\\n<html lang=\\"en\\" itemscope itemtype=\\"https://schema.org/WebPage\\">\\n<head>\\n<meta charset=\\"utf-8\\"><meta name=\\"referrer\\" content=\\"always\\" />\\n<title itemprop=\\"name\\">title I need to select.</title>\\n<meta itemprop=\\"description\\" name=\\"description\\" content=\\><title itemprop=\\"name\\">title I need to select.</title>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);