const regex = /<title.*?>(.*?)<\/title>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<title.*?>(.*?)<\\\/title>', 'g')
const str = `<!doctype html>\\n<html lang=\\"en\\" itemscope itemtype=\\"https://schema.org/WebPage\\">\\n<head>\\n<meta charset=\\"utf-8\\"><meta name=\\"referrer\\" content=\\"always\\" />\\n<title itemprop=\\"name\\">title I need to select.</title>\\n<meta itemprop=\\"description\\" name=\\"description\\" content=\\><title itemprop=\\"name\\">title I need to select.</title>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}