package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi):([a-z]{1,})`)
var str = `SELECT groups.\`name\` FROM authorizations INNER JOIN groups ON groups.id = authorizations.\`group\` WHERE groupid = (SELECT \`group\` FROM user_groups WHERE \`user\` = :USER) AND hubid = :HUBID ORDER BY \`index\` ASC;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}