// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi):([a-z]{1,})").unwrap();
let string = "SELECT groups.`name` FROM authorizations INNER JOIN groups ON groups.id = authorizations.`group` WHERE groupid = (SELECT `group` FROM user_groups WHERE `user` = :USER) AND hubid = :HUBID ORDER BY `index` ASC;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}