import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":([a-z]{1,})";
final String string = "SELECT groups.`name` FROM authorizations INNER JOIN groups ON groups.id = authorizations.`group` WHERE groupid = (SELECT `group` FROM user_groups WHERE `user` = :USER) AND hubid = :HUBID ORDER BY `index` ASC;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}