$re = '/:([a-z]{1,})/mi';
$str = 'SELECT groups.`name` FROM authorizations INNER JOIN groups ON groups.id = authorizations.`group` WHERE groupid = (SELECT `group` FROM user_groups WHERE `user` = :USER) AND hubid = :HUBID ORDER BY `index` ASC;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);