const regex = /:([a-z]{1,})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':([a-z]{1,})', 'gmi')
const str = `SELECT groups.\`name\` FROM authorizations INNER JOIN groups ON groups.id = authorizations.\`group\` WHERE groupid = (SELECT \`group\` FROM user_groups WHERE \`user\` = :USER) AND hubid = :HUBID ORDER BY \`index\` ASC;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}