re = /:([a-z]{1,})/mi
str = 'SELECT groups.`name` FROM authorizations INNER JOIN groups ON groups.id = authorizations.`group` WHERE groupid = (SELECT `group` FROM user_groups WHERE `user` = :USER) AND hubid = :HUBID ORDER BY `index` ASC;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end