# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\w+\K\h+/\n/gm;t' <<< "Filename.mp3 file anem.mid fi le nam e.rm"