import re
regex = re.compile(r"\.\w+\K\h+", flags=re.MULTILINE)
test_str = "Filename.mp3 file anem.mid fi le nam e.rm"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)