using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.\w+\K\h+";
string substitution = @"\n";
string input = @"Filename.mp3 file anem.mid fi le nam e.rm";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}