const regex = new RegExp('\\.\\w+\\K\\h+', 'gm')
const str = `Filename.mp3 file anem.mid fi le nam e.rm`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);