$re = '~\.\w+\K\h+~m';
$str = 'Filename.mp3 file anem.mid fi le nam e.rm';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;