use strict;
my $str = 'Filename.mp3 file anem.mid fi le nam e.rm';
my $regex = qr~\.\w+\K\h+~mp;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";