#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+:\d+:\d+) \+running (\w+)(?:\n(\d+:\d+:\d+) \-running)?"
Local $sString = "00:00:00 +running A" & @CRLF & _
"00:00:01 -running" & @CRLF & _
"00:00:02 +running B" & @CRLF & _
"00:00:03 +running B" & @CRLF & _
"00:00:04 -running" & @CRLF & _
"00:00:05 +running C" & @CRLF & _
"00:00:06 -running" & @CRLF & _
"00:00:07 +running D" & @CRLF & _
"10:00:08 -running"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")