$re = '/(\d+:\d+:\d+) \+running (\w+)(?:\n(\d+:\d+:\d+) \-running)?/m';
$str = '00:00:00 +running A
00:00:01 -running
00:00:02 +running B
00:00:03 +running B
00:00:04 -running
00:00:05 +running C
00:00:06 -running
00:00:07 +running D
10:00:08 -running';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);