use strict;
my $str = '00:00:00 +running A
00:00:01 -running
00:00:02 +running B
00:00:03 +running B
00:00:04 -running
00:00:05 +running C
00:00:06 -running
00:00:07 +running D
10:00:08 -running';
my $regex = qr/(\d+:\d+:\d+) \+running (\w+)(?:\n(\d+:\d+:\d+) \-running)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}