using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+:\d+:\d+) \+running (\w+)(?:\n(\d+:\d+:\d+) \-running)?";
string input = @"00:00:00 +running A
00:00:01 -running
00:00:02 +running B
00:00:03 +running B
00:00:04 -running
00:00:05 +running C
00:00:06 -running
00:00:07 +running D
10:00:08 -running";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}