import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+:\\d+:\\d+) \\+running (\\w+)(?:\\n(\\d+:\\d+:\\d+) \\-running)?";
final String string = "00:00:00 +running A\n"
+ "00:00:01 -running\n"
+ "00:00:02 +running B\n"
+ "00:00:03 +running B\n"
+ "00:00:04 -running\n"
+ "00:00:05 +running C\n"
+ "00:00:06 -running\n"
+ "00:00:07 +running D\n"
+ "10:00:08 -running";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}