package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+:\d+:\d+) \+running (\w+)(?:\n(\d+:\d+:\d+) \-running)?`)
var str = `00:00:00 +running A
00:00:01 -running
00:00:02 +running B
00:00:03 +running B
00:00:04 -running
00:00:05 +running C
00:00:06 -running
00:00:07 +running D
10:00:08 -running`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}