#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.*Continue\? \[Y\/N]$)(^.*Continue\? \[Y\/N]$)"
Local $sString = "Warning: do you want to proceed, some-more,text. Continue? [Y/N]" & @CRLF & _
"Warning: do you want to proceed, some-more,text. " & @CRLF & _
"som other Y/N tesx [Y/N]" & @CRLF & _
"additional proceed, some-more,text Continue? [Y/N]" & @CRLF & _
"ome-more Continue? [/N]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")