const regex = /(?=^.*Continue\? \[Y\/N]$)(^.*Continue\? \[Y\/N]$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.*Continue\\? \\[Y\\\/N]$)(^.*Continue\\? \\[Y\\\/N]$)', 'gm')
const str = `Warning: do you want to proceed, some-more,text. Continue? [Y/N]
Warning: do you want to proceed, some-more,text.
som other Y/N tesx [Y/N]
additional proceed, some-more,text Continue? [Y/N]
ome-more Continue? [/N]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}