re = /(?=^.*Continue\? \[Y\/N]$)(^.*Continue\? \[Y\/N]$)/m
str = 'Warning: do you want to proceed, some-more,text. Continue? [Y/N]
Warning: do you want to proceed, some-more,text.
som other Y/N tesx [Y/N]
additional proceed, some-more,text Continue? [Y/N]
ome-more Continue? [/N]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end