using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.*Continue\? \[Y\/N]$)(^.*Continue\? \[Y\/N]$)";
string input = @"Warning: do you want to proceed, some-more,text. Continue? [Y/N]
Warning: do you want to proceed, some-more,text.
som other Y/N tesx [Y/N]
additional proceed, some-more,text Continue? [Y/N]
ome-more Continue? [/N]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}