import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^.*Continue\\? \\[Y\\/N]$)(^.*Continue\\? \\[Y\\/N]$)";
final String string = "Warning: do you want to proceed, some-more,text. Continue? [Y/N]\n"
+ "Warning: do you want to proceed, some-more,text. \n"
+ "som other Y/N tesx [Y/N]\n"
+ "additional proceed, some-more,text Continue? [Y/N]\n"
+ "ome-more Continue? [/N]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}