$re = '/(?=^.*Continue\? \[Y\/N]$)(^.*Continue\? \[Y\/N]$)/m';
$str = 'Warning: do you want to proceed, some-more,text. Continue? [Y/N]
Warning: do you want to proceed, some-more,text.
som other Y/N tesx [Y/N]
additional proceed, some-more,text Continue? [Y/N]
ome-more Continue? [/N]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);