using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0|\+84)[1-9][0-9]{8,9}$";
string input = @"0123450679
0103450679
+84103450679
01234567899
0000000000
0
012324
12345
0123456789000000
0012345678
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}