// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0|\+84)[1-9][0-9]{8,9}$").unwrap();
let string = "0123450679
0103450679
+84103450679
01234567899
0000000000
0
012324
12345
0123456789000000
0012345678
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}