const regex = /^(?:0|\+84)[1-9][0-9]{8,9}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0|\\+84)[1-9][0-9]{8,9}$', 'mg')
const str = `0123450679
0103450679
+84103450679
01234567899
0000000000
0
012324
12345
0123456789000000
0012345678
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}