import re
regex = re.compile(r"^(?:0|\+84)[1-9][0-9]{8,9}$", flags=re.MULTILINE)
test_str = ("0123450679\n"
"0103450679\n"
"+84103450679\n"
"01234567899\n"
"0000000000\n"
"0\n"
"012324\n"
"12345\n"
"0123456789000000\n"
"0012345678\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")