$re = '/^(?:0|\+84)[1-9][0-9]{8,9}$/m';
$str = '0123450679
0103450679
+84103450679
01234567899
0000000000
0
012324
12345
0123456789000000
0012345678
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);